hrpsys Documentation

Overview

"hrpsys": Basic RT components and utilities to control robots using OpenRTM. Some notable features:

System requirements

ubuntu 12.04LTS and 14.04LTS are supported.
OpenHRP version 3.1.5 or later is required.
To use python scripts to create RT components, connect ports and get/set properties, OpenRTM-aist-python is also required.

Contents of the package

How to monitor my robot?

In order to monitor your robot using GrxUI, you need to implement IO library for your robot. Please develop a library which has interface defined in iob.h and replace pre-installed libhrpIo.so with it.



hrpsys
Author(s): AIST, Fumio Kanehiro
autogenerated on Sat Nov 3 2018 02:44:23